Results 1 to 2 of 2

Thread: The Bow - Monsters invisible and Stuck loading when trying to enter battles

  1. #1

    Join Date
    Nov 2015
    Posts
    1
    Server
    DE01

    The Bow - Monsters invisible and Stuck loading when trying to enter battles

    Hi all, hopefully someone can help as I've been trying everything to correct this problem if it's on my end.

    I have been playing the game for months without a problem and working on my 2nd character now, working my way through the story quests. Everything was fine until today when I went back to The Bow in Lightlands to find all of the Ninja type monsters invisible (still show a glow around where they should be) and every time I click on a monster to start a battle, the loading "E" in the bottom right corner of the screen shows up and the game just sits there forever.

    I have tried clearning my browser and steam cache, deleted all MMHO game content from steam, and even deleted and reinstalled steam completely. None of these things have helped. And I tried coming to the Bow on my main character with the same results.

    If anyone has any other ideas, please let me know.
    Thanks,

  2. #2
    Community Team BB_Eraya's Avatar
    Join Date
    Aug 2014
    Posts
    2,110
    Server
    DE01
    Hi Xynthor,

    I am sorry to hear you are experiencing difficulties. Did you also try another browser or system/device?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Ubisoft uses cookies to ensure that you get the best experience on our websites. By continuing to use this site you agree to accept these cookies. More info on our privacy.