Results 1 to 3 of 3

Thread: Disconnecting from server

  1. #1

    Join Date
    Aug 2016
    Posts
    7
    Server
    DE01

    Disconnecting from server

    I'm not sure if this has been covered or not, or if anyone really cares or not but.....

    Several times an hour I get a message on screen saying "couldn't connect to server".

    I thought maybe it was my pc playing up so I did all the "clear your cache" "defrag disk" etc tips but still it continues. Also while running around looking for stuff, all buildings, treasure, enemies disappear for a few moments then reappear but I am transported back to where I was a few moments ago.

    Is there a problem with the server? Does it need Rebooting? Has a mouse chewed through a cabled which is now being held together with electrical tape to save money?

    Please fix this issue as I really do enjoy this game, but am starting to play less due to this problem.

    Thanks

  2. #2
    adamskeemer's Avatar
    Join Date
    Jun 2015
    Posts
    104
    Server
    DE01
    Same here

  3. #3
    hiho4488's Avatar
    Join Date
    Oct 2014
    Posts
    51
    Server
    DE01
    I find I have to refresh my browser (Firefox or IE) a few times an hour and have gotten used to this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Ubisoft uses cookies to ensure that you get the best experience on our websites. By continuing to use this site you agree to accept these cookies. More info on our privacy.